Environment
- CB Defense Sensor: 3.1.x and Below
- Microsoft Windows: All Supported Versions
- Nutanix Virtual Machines using VirtIO Network Driver: All Supported Versions
- VMware Virtual Machines using VirtIO Network Driver: All Supported Versions
Symptoms
- Sensor installation hangs and never completes
- No information is displayed for device on the Endpoints page
- Sensor stops checking in
- Reports events after generic network driver is swapped for VirtIO driver in Device Manager
Cause
A known compatibility issue between the CB Defense Sensor and the VirtIO driver
Resolution
- Carbon Black is working to address the issue in a future sensor update.
- If using Nutanix, upgrade Nutanix NIC driver to VirtIO 1.1.3
- Upgrade the CB Defense Sensor to 3.2.x or higher
- If using VMware switch from VirtIO to Generic Network Driver
Additional Notes
- The use of the Sensor Removal Tool may be needed in order to remove an incomplete sensor installation before the sensor can be reinstalled.
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