We’re migrating product documentation to docs.vmware.com, starting with Carbon Black Cloud. Learn more.

Cb Response 6.2.4 Server Release Notes

Cb Response 6.2.4 Server Release Notes

The Cb Response 6.2.4 Server Release Notes document provides information for users upgrading from previous versions as well as users new to the Cloud and On-Prem products. It consists of the following sections:

 

New Features – Describes new and modified features introduced in this sensor release.

Corrective Content – Describes issues resolved by this release as well as more general improvements in performance or behavior.

Known Issues and Limitations – Describes known issues or anomalies in this version.

Contacting Technical Support – Describes ways to contact Carbon Black Technical Support and what information to have ready.

 

Published: November 7, 2018

Target Cloud GA: November 11, 2018

Target On-Prem GA: November 15, 2018

Labels (1)
Attachments
Comments

Please make note to confirm if the clean_requirements_on_remove is disabled in your environment before proceeding with the upgrade.

grep 'clean_requirements_on_remove' /etc/yum.conf

Set to 0 to disable and run 'yum clean all' before proceeding

 

If this config was enabled during upgrade and receiving the following error, please use this solution

--------------------------------------------------------------------------------
UPGRADE ABORTED
--------------------------------------------------------------------------------
'rpm -q postgresql93 postgresql93-libs postgresql93-server' failed(2)

https://community.carbonblack.com/t5/Knowledge-Base/Cb-Response-postgresql93-failed-after-upgrading-...

I'm confused, from the release notes:
"Postgres SQL Upgrade (CB-21420)
1. Postgresql93 should be installed during first service startup after 6.2.4 upgrade."
 
Isn't Postgresql 9.3 already installed? Do you mean Postgresql 10? Because the server admin reported that postgresql was updated to 10.

@nverrill, posgres93 is installed in versions prior to 6.2.4. When you upgrade to 6.2.4 we want postgres93 to still be installed. When you run /usr/share/cb/cbupgrade our scripts will do an automated migration to postgres10. If postres93 is not installed when trying to run /usr/share/cb/cbupgrade, the migration will not be able to start and thus you will be in a situation where the services will not be able to start. 

Both will technically be installed, however after migrations and services have successfully started, you can then remove postgres93 and files.

 If you do find yourself in a situation where postgres93 is uninstalled before cbupgrade was run, you can use the following to workaround the issue.

https://community.carbonblack.com/t5/Knowledge-Base/Cb-Response-postgresql93-failed-after-upgrade/ta...

 

Thank you,

Bryce

 

 

Article Information
Author:
Creation Date:
‎11-07-2018
Views:
2575