IMPORTANT ANNOUNCEMENT: On May 6, 2024, Carbon Black User eXchange (UeX) and Case Management will move to a new platform!
The Community will be in read-only mode starting April 19th, 7:00 AM PDT. Check out the blog post!
You will still be able to use the case portal to create and interact with your support cases until the transition, view more information here!

500 Errors After Upgrading to 8.0 from 7.x

500 Errors After Upgrading to 8.0 from 7.x

Version
8.0.x


Issue

After upgrading to 8.0 from 7.x, the systems seems to run out of memory in IIS quicker than before.

Symptoms
The main symptom of this is console 500 errors. It will come back, but will randomly return the 500 errors the longer its up. This can take place in Agent Upgrades, API Usage or Console Usage.

Cause
This is caused by an IIS change that took place in 8.0. Part of the change modified the amount of memory allocated to the DefaultAppPool. Changing the value from the previous higher limit, to 320Mb

Solution

To resolve this issue, an increase in the Private Memory allocation is required. Use the following steps to increase the amount, and re-cycle IIS.

1. Firstly on the CB Protection server open IIS (Internet Information Services (IIS) Manager).

2. Expand the server instance, and click on "Application Pools"

3. Select "DefaultAppPool" from the list and hit the "Recycling" option under the Edit Application Pool menu on the right.

4. Modify the "Private Memory Usage (in KB)" option to be at least 819200.

5. Once the value is saved select the "Recycle" task under the Application Pool Tasks menu on the right to apply the change.

NOTE: Depending on the resources and size of the installation this number may be increased, but a minimum of 819200 is recommended. 
Was this article helpful? Yes No
No ratings
Article Information
Author:
Creation Date:
‎08-30-2017
Views:
688