Environment
- Carbon Black Protection
- Version: 8.0+
Symptoms
Collecting logs that will help support investigation when seeing API errors in the consolePossible errors seen:
- "API authentication failed. Some pages will not be functional. Please try to log out and log in again."
- "API appears not to be accessible."
Cause
A value is missing in the shepherd_configs table that points the API to the WebServer address causing Authentication Failures. This can be seen after an upgrade.
Resolution
- Confirm you are experiencing the same root cause
USE das SELECT * FROM dbo.shepherd_configs WHERE name = 'WebServerAddress' |
- If this result returns nothing, follow these directions for resolution. If results do return with the correct server address, follow the link in the related content.
1) Stop the Cb Protection Server and Cb Protection Reporter services
2) Open SQL Server Management Studio and run the following query (run as is below, no values added)
USE das DECLARE @address NVARCHAR(2048) SELECT @address = value from dbo.shepherd_configs WITH (NOLOCK) WHERE name = 'RPCServerAddress'EXEC dbo.updateshepherdconfig @name = 'WebServerAddress', @value = @address |
3) After completion, restart the Cb Protection Server and Cb Protection Reporter services to force the change
4) Log into the Carbon Black Protection Console and confirm this is has been resolved.
Additional Notes
This only appears to happen after a major version upgrade to 8.0. Reason is unknown, however after correction this will no longer need to be run.
Related Content
Links to other documents which may have similar symptoms, in case this solution was not the resolution.
Cb Protection: IIS Configurations for 8.0 and newer