Threat Report: Exposing Malware in Linux-Based Multi-Cloud Environments | Download Now

Agent deployed on a Mac client is not associated with any Bit9 Server

Agent deployed on a Mac client is not associated with any Bit9 Server

Version

7.0.x, 7.2.x

 

Issue

Bit9 agent installed on a Mac machine is not showing on Bit9 Console.

 

Symptoms

The Bit9 Agent is installed using a deployment tool (e.g. Casper). After the Bit9 Agent installation, it is not showing on the Bit9 console.

 

./b9cli --status returns the following information:

 

CurrentTime[Tue Sep 16 16:34:57 2014]

Version Information

CLI: 7.2.0.10302 Thu Aug 28 19:11:27 2014 (Patch 3)

Server: Not Connected

Agent: 7.2.0.10302 Thu Aug 28 19:11:27 2014 (Patch 3)

Kernel: 7.2.0.10302 Thu Aug 28 19:11:27 2014 (Patch 3)

 

Enforcement Information

Current: None (Disabled)

Connected: None (Disabled)

Disconnected: None (Disabled)

Kernel: None (Disabled)

 

Cache Information

Cache State: Pre-initialization (Priority 1) (0%)

Cache Check: Not running

Global Approvals: 0 (0 Active)

Global Bans: 0 (0 Active)

Local Files: 0 (0 cached, 0 lingering)

Local Names: 0 (0 cached, 0 not persistent)

Remote Files: 0

Under Analysis: 0 Started, 0 Ready, 0 Initiated

Analyzed: 1

Database Read Pool: Active:2, Available:2, Max:0

Database R/W Pool: Active:1, Available:1, Max:0

Database Server Pool: Active:1, Available:1, Max:1

Database Ops: 0 Outstanding, 71 Processed

Kernel Ops: 0 Outstanding, 0 Max queue ms

 

Server Information

Server: :0

Status: Unknown

Policy: (0-00000000)

Config List: 0 of 0 (100%)

Unsent Events: 1 (0 not ready, 0 total)

Unsent Updates: 0 (0 not ready)

Sent Queue: 0-0

Prioritized: No

 

Client Information

Connection: Disconnected(HTTP Error 0)

Session: Inactive

Certificates: Verify, Allow Expired

Debug Level: None (0) Duration: Session

Kernel Level: 2/00000000

Dump Format: Full (0 found)

Network Trace: Disabled

Tamper Protection: Enabled

System Update: Inactive

SSL Mode: SSL

 

Cause

The results above indicates that the agent installation was not done by pushing the entire DMG file. The PKG expects the configlist.xml and other server.config files to be in the same directory as the main package.

 

Solution

Make sure that the entire DMG is pushed by the deployment tool and not only one package.

Labels (1)
Was this article helpful? Yes No
No ratings
Article Information
Author:
Creation Date:
‎01-07-2015
Views:
1342
Contributors