Threat Report: Exposing Malware in Linux-Based Multi-Cloud Environments | Download Now

Agent is failing to upgrade when Windows Installer service is stopped

Agent is failing to upgrade when Windows Installer service is stopped

Version

6.0.x

7.0.x

 

Issue

Agents are failing to upgrade with the following message in the console:

       Agent Upgrade: Failed executing C:\ProgramData\Bit9\Parity Agent\Parity7.0MaintenancePack.msp

       /qN /l*v+ "\\?\globalroot\device\harddiskvolume1\programdata\bit9\parity

       agent\logs\ParityHostAgent70Upgrade.log". Upgrade did not start after download

 

Symptoms

The following error is logged in the upgrade log file on the agent machine (can be found usually under %PROGRAMDATA%\Bit9\Parity Agent\Logs and on Windows XP/ server 2k3 under %APPDATA%\Bit9\Parity Agent\Logs ):

       === Verbose logging started: 5/30/2014  17:44:48  Build type: SHIP UNICODE 5.00.7601.00 

      Calling process: C:\Windows\SysWOW64\msiexec.exe ===

       MSI (c) (84:C4) [17:44:48:073]: Resetting cached policy values

       MSI (c) (84:C4) [17:44:48:073]: Machine policy value 'Debug' is 0

       MSI (c) (84:C4) [17:44:48:073]: ******* RunEngine:

                ******* Product: {ADC7EB41-4CC2-4FBA-8FBE-9338A9FB7666}

               ******* Action:

                ******* CommandLine: **********

       MSI (c) (84:C4) [17:44:48:073]: Client-side and UI is none or basic: Running entire install on the

       server.

       MSI (c) (84:C4) [17:44:48:073]: Grabbed execution mutex.

       MSI (c) (84:C4) [17:45:18:103]: Failed to connect to server. Error: 0x80080005

 

       MSI (c) (84:C4) [17:45:18:103]: Failed to connect to server.

       MSI (c) (84:C4) [17:45:18:103]: MainEngineThread is returning 1601

       === Verbose logging stopped: 5/30/2014  17:45:18 ===

 

Cause

The server referred in the log is not the Bit9 server but the Windows Installer service on the actual agent machine. When the Windows Installer service is down or disabled the Bit9 Agent upgrade will fail with the above error in the log.

Running: net helpmsg 1601 from command line, will show the following explanation for this error:

The Windows Installer Service could not be accessed. This can occur if the Windows Installer is not correctly installed. Contact your support personnel for assistance.


Solution

  1. Start the Windows Installer service in the upgraded machine      and make sure it is running
  2. Repeat the upgrade
Was this article helpful? Yes No
100% helpful (2/2)
Article Information
Author:
Creation Date:
‎12-21-2015
Views:
2700