Version
6.0,
Issue
Agent never completes synchronization.Symptoms
- Files on Computers shows a full compliment of files on this endpoint (13000+) but synch percentage stays at 0.
- Attempt to send "resync" command and UI reports that a resync is already in progress - which explains why the server shows 0%.
- Sync status never changes.
- Database errors in events
- Failed upgrades
Cause
Many potential root causes. One example is (regarding sync) is that the server is correctly sending resync requests, but the agent cannot perform the action due to a corrupt database. As a result, it cannot clear its queue:08:20:00 85500559 ( 1232) - DATABASE: [1232] Error running statement: database disk image is malformed [lasterr=0000000B]As a result, the agent's queue is never going down since the server keep flushing until it receives the resync start message.
Solution
1. Look for an invalid_cache.bt9 file located in the Agent data directory:
XP/2003 Server (and older): \documents and settings\all users\application data\bit9\parity agent
Vista/Win7/ 2008 server (and newer): \programdata\bit9\parity agent\
2. Collect a copy of the current cache in use by the agent.
Go to Computer Details > Advanced Settings > Upload Agent cache. Collect it in the https://<YourParityServer>/support.php page under "view available log files."
You can also collect it via "dascli copycache C:\cache.db"