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App Control: AD Policy mappings not working with SOAP timeout errors

App Control: AD Policy mappings not working with SOAP timeout errors

Environment

  • App Control Server: 8.1.x - 8.8.x

Symptoms

API Errors similar to:
GET CB_Server.domain.net/api/bit9platform/v1/fileInstanceGroup/ results in "Cannot expand field certificateid" 
PHP Fatal error: Maximum execution time of <time> seconds exceeded in C:\Program Files (x86)\Bit9\Parity Console\WebUI\include\Objects\ApiCall.php on line <number of line>

Cause

ScriptResultSetLimit value set where it exceeds response buffer size limit
ResponseBufferLen needs to be set to a higher value than the default (64*1024=65536)

Resolution

This issue was resolved with the release of Server 8.9.0 and upgrading will resolve the issue.

Additional Notes

  • App Control Server 8.9.0 included a rewrite that no longer uses the old AD scripts by default.
  • If AllowADScripts was set to true, this issue could return. The previous workaround is as follows:
    1. Log in to the Console and navigate to https://ServerAddress/shepherd_config.php
    2. Locate the Property: ScriptResultSetLimit
    3. Change the Value to 250. (Prevents exceeding the Response Buffer max size: 64*1024 bytes which equals 65536)
    4. Locate the Property: ResponseBufferLen
    5. Change the Value to 83968 to support a larger chunk of data that would be generated.
    6. Restart both the App Control Server and App Control Reporter services

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Creation Date:
‎09-09-2020
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