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App Control: API is Not Reachable Errors on Console

App Control: API is Not Reachable Errors on Console

Environment

  • App Control:  7.x and 8.x
  • App Control on DMZ
  • Red Dot and 'API is not reachable' on Administration > System Configuration > Advanced Options > API Access Enabled

Symptoms

  • 'API is unavailable. This page will not be functional' errors when loading console pages
  • 'You are not authorized to view this page' errors when loading console pages
  • Blank User Roles when trying to Edit or Create a new User
  • Unable to Globally Approve files
  • Unable to view Software Rules page
  • 'API Error from page....returned http code 404' error in PHP_Errors.log

Cause

  • These errors are a result of the API not being able to communicate with the server, due to the server being on a DMZ and not being able to reach out to the DNS server for host name resolution.

Resolution

  1. Add the following entry to the Host File of the App Control Server, located at C:\Windows\System32\Drivers\ETC: 
    127.0.0.1 <FQDN>
  2. Run the following command to flush the DNS records, allowing the host file change to take place:
    ipconfig /flushdns
  3. Log out and back in to the console.

Additional Notes

  • The 'Server Address' listed in the Console -> Gear dropdown -> System Configuration -> General tab needs to match the <FQDN> being added to the host file

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Creation Date:
‎03-12-2019
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