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App Control: After Console Upgrade to 8.8.0 some AD users are getting web page errors

App Control: After Console Upgrade to 8.8.0 some AD users are getting web page errors

Environment

  • App Control Console: 8.8.0

Symptoms

  1. Upgraded the console to version 8.8.0
  2. Logged into the console with an AD user account and:
  • Software Rules shows "Something Went Wrong" error
  • Events page displays "Your API session has expired" error
  • Checking the API status shows a red dot
  • PHP_errors log has multiple 401 errors

Cause

Due to changes in the API session process in version 8.8 when an AD account has User Logon Name that is different than the User Logon Name (Pre-Windows 2000) in Active Directory then the user gets invalid API session resulting in web page errors when browsing the console


Resolution

This issues is resolved in App Control version 8.8.2 and until the upgrade is available you can:

  • Local users or SAML users are not affected, so you can use the admin or another local user account for management purposes
  • There is a hotfix available, please open a support case to request it

Additional Notes

This issue is tracked as EP-14954 and it will be referenced in the 8.8 server release notes

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Creation Date:
‎01-08-2022
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