Environment
- App Control Agent: All Supported Versions
- App Control Console: All Supported Versions
- Microsoft Windows: All Supported Versions
Symptoms
When upgrading the Agent via the Console the upgrade fails and the error returned to the Computer Details page in the Console shows:
"Agent upgrade: Failed executing Installer[c:\programdata\bit9\parity agent\parityhostagent.msi] Cmdline[User[NT AUTHORITY\SYSTEM]]. Upgrade installer ended without stopping the agent."
Cause
There are many reasons why this message could be displayed, these include:
- Failure of the Code Signing/Counter Signing certificates used to validate the ParityHostAgent.msi file.
- Remnants from a previous Agent installation, preventing the upgrade.
- Some other Pre-installation Check failing, causing the Agent to not upgrade.
Resolution
The full ParityHostAgentInstall_TIMESTAMP.log file on the endpoint should be reviewed for further confirmation, however some common ways to resolve these issues include:
- Verify Agent Exclusions are in place (Windows, macOS, Linux) with other antivirus/security/scanning software.
- Issue a Global Approval for the new hash of the ParityHostAgent.msi file, and remove the pending Upgrade Attempt to allow the Agent to receive the new Approval.
- Verify Add/Remove Programs shows only one version of the Agent installed.
- Verify Registry Keys from previous versions are not present.
- Test manually upgrading an Agent via the command line.
Additional Notes
If the upgrade continues to fail please collect the full upgrade log from the endpoint open a case with Technical Support and provide a copy of the failed log from the endpoint, which should be located in:
"C:\ProgramData\Bit9\Parity Agent\Logs\ParityHostAgentInstall_TIMESTAMP.log"
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