Environment
- App Control Agent: All Supported Versions
- App Control Console: All Supported Versions
Symptoms
Agent shows as "Upgrade Blocked" within the Assets > Computers > "Upgrade Status" column.
Cause
The Configlist Version (CL Version) on the endpoint is lower than the CL Version for Upgrade as shown at the top of the page in the Console > Assets > Computers.
Resolution
Additional Notes
- When a new Agent Host Package installer is uploaded to the Server the current Configlist Version is written to the Shepherd Config MinConfigListVersionForUpgrade
- If the Agent has been disconnected for an extended period, then it is possible the Configlist will need to be manually pushed.
- Confirm "Automatic Agent Upgrades" (Server 8.9 or Earlier) or "Allow Agent Upgrades" (Server 8.10 and Higher) setting is enabled.
- The Agent can also be manually upgraded (See Related Content).
Related Content