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App Control: Agent Upgrade Status "Upgrade Blocked"

App Control: Agent Upgrade Status "Upgrade Blocked"

Environment

  • App Control Agent: All Supported Versions
  • App Control Console: All Supported Versions

Symptoms

Agent shows as "Upgrade Blocked" within the Assets > Computers > "Upgrade Status" column.

Cause

The Configlist Version (CL Version) on the endpoint is lower than the CL Version for Upgrade as shown at the top of the page in the Console > Assets > Computers.

Resolution

  1. Verify the Agent is showing as Connected in Assets > Computers.
  2. Remove the pending Agent Upgrade so the Configlist Updates to the endpoint will resume.
  3. Verify the Agent is not a Duplicate Computer, and re-register if necessary.
  4. Navigate to Assets > Computers > Show Columns > add CL Version > Apply.
  5. Verify the Agent's CL Version meets or exceeds "CL Version for Upgrade before attempting to upgrade again.
  6. If necessary, navigate to https://ServerAddress/shepherd_config.php and change the Property MinConfigListVersionForUpgrade to match the Current CL Version.
If the issue persists, or is impacting multiple machines at the same time, further investigation will be required.

Additional Notes

  • When a new Agent Host Package installer is uploaded to the Server the current Configlist Version is written to the Shepherd Config MinConfigListVersionForUpgrade
  • If the Agent has been disconnected for an extended period, then it is possible the Configlist will need to be manually pushed.
  • Confirm "Automatic Agent Upgrades" (Server 8.9 or Earlier) or "Allow Agent Upgrades" (Server 8.10 and Higher) setting is enabled.
  • The Agent can also be manually upgraded (See Related Content).

Related Content


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Creation Date:
‎07-06-2016
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