Environment
- App Control Console: All Supported Versions
- App Control Agent: All Supported Versions
- Microsoft Windows: All Supported Versions
Symptoms
Cause
- Another installation is taking place at the same time as the upgrade was requested (Rare Event).
- Multiple instances of msiexec.exe are running on the endpoint.
Resolution
Reboot the endpoint to be sure pending software installations have completed, and the Windows Installer Service is once again available to be used by the Agent upgrade process.
Additional Notes
In some instances the Agent will show as Disconnected due to this failure during the upgrade process, but should become Connected after the reboot.
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