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App Control: CDC Connectivity Error "The Client and Server Cannot Communicate Because They Do Not Possess a Common Algorithm"

App Control: CDC Connectivity Error "The Client and Server Cannot Communicate Because They Do Not Possess a Common Algorithm"

Environment

  • App Control Server: 7.x - 8.x
  • Microsoft Windows Server: All Supported Versions
  • TLS 1.0 disabled

Symptoms

Error in console
  • "Collective Defense Cloud / Bit9 Software Reputation Service Unavailable"
Error in C:\Program Files (x86)\Bit9\Parity Server\Reporter\ParityReporter.txt
  • "An unexpected error occurred on a receive. ---> System.ComponentModel.Win32Exception: The client and server cannot communicate, because they do not possess a common algorithm"

Cause

.Net not using the latest TLS version

Resolution

  1. Add DWORD entries to the registry of the App Control application server:
    • [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319] "SchUseStrongCrypto"=dword:00000001
    • [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\.NETFramework\v4.0.30319] "SchUseStrongCrypto"=dword:00000001
  2. Restart the App Control Server

Additional Notes

Adding the registry keys will force .Net to use the latest version of TLS

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Creation Date:
‎07-24-2017
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2543
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