Environment
- App Control Server: All Supported Versions
- Microsoft Windows Server: All Supported Versions
Symptoms
Error in Console
Errors in "C:\Program Files (x86)\Bit9\Parity Server\Reporter\ParityReporter.log"
Cause
Missing certificates in the application server's trust store
Resolution
- Login to the App Control Server hosting with the Carbon Black Service Account
- Go to: https://services.bit9.com/Services/search.aspx
- Verify the certificate information by clicking the padlock icon and viewing the certificate information > Details tab > Copy to file
- Depending on the browser, these steps may be worded slightly differently
- Run > certlm.msc and verify the certificates are in Trusted Root Certification Authorities and Intermediate Certifications Authorities
- If missing, download via web browser and import into the application servers trust store
- Open an elevated command prompt to issue the following:
iisreset
net stop parityserver
net stop parityreporter
net start parityserver
net start parityreporter
Additional Notes
App Control use Digicert signed certificates for SSL communication. Therefore the Digicert certificate must be present in the certificate trust store located on the App Control application server
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