Environment
- App Control Console: All Supported Versions
- Microsoft Windows Server: All Supported Versions
Symptoms
Error when launching App Control Console:
- "The Carbon Black App Control console cannot connect to the database. Ensure that the database server is running. If the issue persists, contact Carbon Black technical support."
- "The Cb Protection Console cannot connect to the database. Ensure that the database server is running. If the issue persists, contact Carbon Black technical support."
- "Fatal Error: The Carbon Black App Control Console cannot connect to the database. Ensure that the database server is running. If the issue persists, contact Carbon Black support"
- "Network error while trying to communicate with Carbon Black App Control Server"
- "Error: Could not connect to host"
Cause
- Network connectivity to SQL server has been disrupted (Two Tier Environments)
- SQL Server services are not running or SQL role permissions are missing
- App Control Server/App Control Reporter service password was changed
- IIS DefaultAppPool identity is not correctly set
- CB SQL Server not meeting OER
- Das DB was changed to a different SQL Instance without reinstalling App Control application
- Other
Resolution
- Login to the App Control Server
- Confirm network connectivity between App Control Server and App Control SQL server (if Two Tier).
- Confirm status of App Control Server, App Control Reporter, and SQL Server services:
- Go to Start > Run > type “services.msc" > click OK.
- Find "App Control Server", "App Control Reporter", and "SQL Server" service:
- Confirm status is "running" for each service
- Right click "App Control Server" service > Properties > log on tab
- Fill in password, click "apply"
- Right click "App Control Reporter" service > Properties > log on tab
- Fill in password, click "apply"
- Confirm Windows Permission Required
- Confirm SQL Permission
- Verify IIS identity for the DefaultAppPool
- Confirm SQL Server is meeting OER depending the App Control Server Version installed
- If SQL Instance was changed, uninstall and reinstall App Control Server application, information is published in Server Installation Guide
- Other
- Collect App Control Server troubleshooting logs
- Collect Event Viewer logs from App Control Application and App Control SQL Server
- Collect SQL Server logs
- Upload the collected logs to the CB Vault and provide an update on the relevant Support Case.
Related Content