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App Control Console: "The Carbon Black App Control console cannot connect to the database"

App Control Console: "The Carbon Black App Control console cannot connect to the database"

Environment

  • App Control Console: All Supported Versions
  • Microsoft Windows Server: All Supported Versions

Symptoms

Error when launching App Control Console:
  • "The Carbon Black App Control console cannot connect to the database. Ensure that the database server is running. If the issue persists, contact Carbon Black technical support."
  • "The Cb Protection Console cannot connect to the database. Ensure that the database server is running. If the issue persists, contact Carbon Black technical support."
  • "Fatal Error: The Parity Console cannot connect to the Parity Server database. Ensure that the database server is running. If the issue persists, contact Bit9 technical support."

Cause

  • Network connectivity to SQL server has been disrupted (Two Tier Environments)
  • SQL Server services are not running or SQL role permissions are missing
  • App Control Server/App Control Reporter service password was changed
  • IIS DefaultAppPool identity is not correctly set
  • CB SQL Server not meeting OER
  • Das DB was changed to a different SQL Instance without reinstalling App Control application
  • Other

Resolution

  1. Login to the App Control Server
  2. Confirm network connectivity between  App Control Server and  App Control SQL server (if Two Tier).
  3. Confirm status of App Control Server, App Control Reporter, and SQL Server services:
    1. Go to Start > Run > type “services.msc" > click OK.
    2. Find "App Control Server", "App Control Reporter", and "SQL Server" service:
    3. Confirm status is "running" for each service
    4. Right click "App Control Server" service > Properties > log on tab
    5. Fill in password, click "apply"
    6. Right click "App Control Reporter" service > Properties > log on tab
    7. Fill in password, click "apply"
  4. Verify IIS DefaultAppPool:
    1. Go to Start > Run > type “inetmgr" > click OK.
    2. The Internet Information Services (IIS) Manager will open.
    3. On the IIS Manager navigation tree on the left-pane, select the server name.
    4. Expand server name > Click "Application Pools"
    5. Right click "DefaultAppPool" > Advanced Settings
    6. Verify Identity is set to the CB Protection Service account (Shown in step 3)
  5. Confirm SQL Server is meeting OER
  6. If SQL Instance was changed, uninstall and reinstall CB Protection Server application:
  7. Other
    1. Collect server troubleshooting logs
    2. Collect Event Viewer logs from CB Protection Application and CB Protection SQL Server:
    3. Collect SQL Server logs:

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Creation Date:
‎09-09-2020
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