Environment
- App Control Agent: All Supported Versions
- Apple macOS: All Supported Versions
- Third Party Deployment Tools such as JAMF or Casper
Symptoms
- Newly installed agent is disconnected from the server.
- The command ./b9cli --status returns the following fields:
- Server: Not Connected
- Server: :0
- Status: Unknown
Cause
This is caused by the deployment tool only pushing the PKG for the installer, not the entire DMG. Because only the PKG is being pushed, the install is missing two required files:
- configlist.xml
- server.config
Resolution
- If the Agent is already installed, an uninstall of the Agent via Safe Mode is required.
- Update the deployment package you're using to verify that the Configlist.xml and server.config files are in the same directory as the main package.
- Install the Agent.
Additional Notes
The DMG contains an internal pkg file along with a hidden configlist.xml and server.config that can be used for pushing out
Related Content