Environment
- App Control Agent: All Supported Versions
- Microsoft Exchange Server: All Supported Versions
Symptoms
Long periods of high CPU usage by number of MS Exchange processes (e.g. msexchangerepl.exe) that are causing performance bottlenecks and that can lead to temporary service disruptions
Cause
During high CPU utilization the App C agent driver (Parity.sys) is spending too much time holding up the MS Exchange processes in kernel mode while evaluating file operations against existing rules
Resolution
- Log in to the Console and navigate to Rules > Software Rules > Rapid Configs > Microsoft Exchange Server.
- Verify the Rapid Config is Enabled and applied to all relevant Policies.
- Reduce the number of Custom rules active on the Exchange Servers:
- Isolate the Exchange Servers in a separate Policy
- Ensure that Custom Rules meant for Desktop systems are not applied to the Exchange Server Policy
- If the performance issues continue, please add a set of Kernel Exclusions as recommended in this MS Exchange KB:
- Navigate to https://ServerAddress/agent_config.php > Add Agent Config:
Name: Exchange Process Exclusions (or something memorable)
Host ID: 0
Value:
kernelProcessExclusions=*\program files\microsoft\exchange server\v*\Microsoft.Exchange.*.exe:4194303,*\program files\microsoft\exchange server\v*\MSExchange*.exe:4194303,*\program files\microsoft\exchange server\v*\edgetransport.exe:4194303,*\program files\microsoft\exchange server\v*\hostcontrollerservice.exe:4194303,*\program files\microsoft\exchange server\v*\noderunner.exe:4194303
Platform: Windows
Status: Enabled
Create For: Select only the relevant Exchange Server Policy
- Save, and add another Agent Config:
Property Name: Exchange FileOp Exclusions (or something memorable)
Host ID: 0
Value:
kernelFileOpExclusions=*.log:4194303,*.jsl:4194303,*.edb:4194303
Platform: Windows
Status: Enabled
Create For: Select only the relevant Exchange Server Policy
- Save the Agent Config and verify the relevant Agents show as Connected & Up to Date.
- Verify the Agents show as Connected & Up to Date then test for continued performance issues.
Additional Notes
- Not every Exchange server will experience performance issues and the need to have the kernel exclusions applied
- If unsure what exclusions are needed please collect agent logs then create support case for performance issues
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