Environment
- App Control Console: All Supported Versions
- App Control Agent: All Supported Versions
- Allow Upgrades Policy Setting: Enabled
- Automatic Agent Upgrades: Disabled
Symptoms
Push upgrade options do not appear in the console despite policy settings set to allow.
Cause
This is caused by a configuration mismatch. The Allow Upgrades setting is for the server automated upgrades, and the push upgrade options are enabled using the System Configuration > Advanced Options > Automatic Agent Upgrades setting.
Resolution
- Disabled the Allow Upgrades option in all policies
- Navigate to Administration (Gear Icon) > System Configuration > Advanced Options
- Enable "Automatic Agent Upgrades"