Environment
- App Control Server: 8.1.4 and Higher
Symptoms
- After upgrading to App Control Server 8.1.4, uploading a new agent installer to the server fails.
- The C:\Program Files (x86)\Bit9\Parity Server\Support\HostPackageInstall*.log may contain "ERROR: Unable to back up files"
Cause
This happens because during this process, App Control runs a backup of the Parity Server install directory "*\bit9\Parity Server" to the local user's temp directory. If it runs out of disk space during the backup the install will fail.
Resolution
- Stop the App Control Server service
- Delete any ####.tmp files or folders created in this directory:
C:\Users\<ServiceAccount>\Appdata\Local\Temp
- Run the most recent host package installer exe file
- Start the App Control Server service
Additional Notes