Version
All.
Issue
When the "Parity Server" service is started and running, the Bit9 Console returns a network error.
Symptoms
The Bit9 Console shows the following error when opening the page in your browser:
Network error while trying to communicate with Parity Server.
Error: Could not connect to host
In addition, the "Parity Server" service will show as started, parityserver.exe is running in Task Manager, and no errors appears in the logs, event viewer, or in tools such as DebugView.
Cause
There is a known issue impacting Windows Server 2003 and Windows Server 2008. Please see this Microsoft KB for additional information: http://support.microsoft.com/kb/931908
Solution
Perform the steps outlined in Microsoft KB 931908; either install the hot fix or manually delete the files in the service user's temp directory. (Directory will be C:\Users\<bit9 useraccount>\AppData\Local\Temp on Windows 2008 and newer servers)
Important Note
Windows Vista hotfixes and Windows Server 2008 hotfixes are included in the same packages. However, only "Windows Vista" is listed on the Hotfix Request page. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows Vista" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.