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Bit9 agent upgrade failed because it was unable to start the ParityDriver

Bit9 agent upgrade failed because it was unable to start the ParityDriver

Version

6.0.2.x & 7.x

 

Issue

Bit9 agent upgrade failed because it was unable to start the ParityDriver.

 

Symptoms

Upgrade log shows the following failure error message:

1: <Bit9 Log> Starting ParityDriver

1: <Bit9 Log> (FAILURE) Unable to start ParityDriver service

 

Cause

The old Parity Driver was not deleted. There are 2 different versions of Parity Driver files on the system. Another cause could be a separate security application that prevented the Parity Driver from loading.

 

Solution

  1. On the endpoint, run the following on an elevated command prompt while in the %program files%\Bit9\Parity Agent directory:
    dascli password {CLI password here}
    dascli tamperprotect 0
    net stop parity
    fltmc unload paritydriver
  2. Go to C:\Windows\System32\Drivers and delete the Parity.sys file.
  3. Go to C:\Windows\System32\DRVSTORE\ and delete the Parity_... folder.
  4. Open the registry and go to HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\DIFX and delete the Parity_... registry key folder if it’s still present.
  5. Follow solution 274 for the manual Bit9 agent upgrade but add NOSTARTPARITY and NOSTARTDRIVER on the command.
    Example:
    msiexec /i {path}\{filename}.msi NOSTARTPARITY=1 NOSTARTDRIVER=1 /l*v {path}\manual_install.log
    msiexec /p {path}\{filename}.msp NOSTARTPARITY=1 NOSTARTDRIVER=1 /l*v {path}\manual_install.log
  6. On the registry, go to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\paritydriver. Add the DWORD called "Start" if it’s not present and set it to 0.
  7. Reboot the machine.
  8. Open a command prompt and change directory to %program files%\Bit9\Parity Agent. Run “dascli status” to verify the version.
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Creation Date:
‎01-16-2015
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