IMPORTANT ANNOUNCEMENT: On May 6, 2024, Carbon Black User eXchange (UeX) and Case Management will move to a new platform!
The Community will be in read-only mode starting April 19th, 7:00 AM PDT. Check out the blog post!
You will still be able to use the case portal to create and interact with your support cases until the transition, view more information here!

Bit9 console is not accessible with a fatal error "Parity server took too long to answer"

Bit9 console is not accessible with a fatal error "Parity server took too long to answer"

Version:

6.0.2.x

7.x

 

Issue:

Bit9 console is not accessible with a fatal error "Parity server took too long to answer"

 

Symptoms:

After new installed Bit9 server, Bit9 console is not accessible and always get the "Fatal Errors:

Timeout happened while trying to communicate with Parity Server"; "Error: The Parity Server took too long to answer"; "Make sure that Parity Server and SQL database are both running and accessible."

 

Cause:

Domain resolved name has mismatched IP address. Example: Console was attempting to contact the bit9 server's domain name as test_server.bit9.com in IP Address of 199.16.12.112, but the IP Address of the physical machine hosting the Bit9 Console is actually 199.16.13.9.

 

Solution:

Workaround solution:

Changed the reference to Bit9 server's IP address in console configuration file:

(C:\Program Files (x86)\Bit9\Parity  or C:\Program File\Bit9\Parity Console\WebUI\include\parity.ini)

Permanent solution:

Fix the DNS resolution on the network

Was this article helpful? Yes No
No ratings
Article Information
Author:
Creation Date:
‎12-08-2015
Views:
623