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Carbon Black Cloud: Sensor Upgrade Failing To Install After Initial GPO/SCCM Deployment

Carbon Black Cloud: Sensor Upgrade Failing To Install After Initial GPO/SCCM Deployment

Environment

  • Carbon Black Cloud sensor: All Versions
  • Microsoft Windows: All Supported Versions

Symptoms

  • Original install utilized GPO or SCCM
  • Uninstallation of previous sensor and installing over the top via GPO/SCCM/Unattended
  • Manual upgrade fails and the current version is not upgraded

Cause

Additional checks were added to verify that sensors installed via GPO are configured by GPO to allow updates to be pushed from the Cloud or installed manually.

Resolution

  1. Open regedit and navigate to HKEY_CLASSES_ROOT\Installer\Products\{Cb Defense GUID}
  2. Within this registry, take a note of the ‘ProductIcon’ Data
    Example
    C:\WINDOWS\Installer\{Product Code}\MainIcon.ico
  3. Navigate to C:\WINDOWS\Installer\ and delete the folder with same {Product Code} as above
  4. Delete the {Cb Defense GUID} from the registry
  5. Re-run the installer

Additional Notes


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Creation Date:
‎09-09-2020
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