Environment
- CB Protection Console: All Supported Versions
Symptoms
- Old certificate is not getting updated even after successfully importing the new server certificate
- After importing the new server certificate, a message shows on the top for “New certificate was successfully imported and applied”
- Browser gives security warning and shows old certificate
Cause
- The local computer certificate store still has the old server certificate
- Certificate hasn't been updated in IIS
Resolution
Import the new server certificate to IIS and bind it to port 443:
Delete the old certificate from the local computer’s certificate store:
- Login to theCB Protection server
- Navigate to Start > Run > type “mmc” > click OK.
- On the Microsoft Management Console (mmc) window, go to the File menu > click on “Add/Remove Snap-in”
- Select “Certificates” > click the “Add” button
- Select “Computer account” > click “Next” > select “Local computer” > click “Finish” > then, click “OK
- Delete the old CB Protection server certificates from the following locations:
- Personal > Certificates
- Trusted Root Certification Authorities > Certificates
- Trusted People > Certificates
- Open an admin CMD prompt
- Run command:
iisreset
- Open Services.msc
- Restart the CB Protection Server and CB Reporter services