Version
This solution applies to all Carbon Black versions.
Issue
From the Carbon Black UI: Administration -> Alliance Feeds -> the message is displayed: "No configured feeds."
Symptoms
From the Carbon Black Enterprise Server, the following is present in the logs /var/log/cb/allianceclient/allianceclient.log:
May 13 09:44:20 [1563] <err> cb.alliance.client -
...ome/cb/.jenkins/jobs/build-cbent-hotfix-4.1.5/workspace/code/coreservices/src/cb/utils/requests/api.py", line 88, in post
File "/home/cb/.jenkins/jobs/build-cbent-hotfix-4.1.5/workspace/code/coreservices/src/cb/utils/requests/api.py", line 44, in request
File "/home/cb/.jenkins/jobs/build-cbent-hotfix-4.1.5/workspace/code/coreservices/src/cb/utils/requests/sessions.py", line 363, in request
File "/home/cb/.jenkins/jobs/build-cbent-hotfix-4.1.5/workspace/code/coreservices/src/cb/utils/requests/sessions.py", line 466, in send
File "/home/cb/.jenkins/jobs/build-cbent-hotfix-4.1.5/workspace/code/coreservices/src/cb/utils/requests/adapters.py", line 350, in send
ConnectionError: HTTPSConnectionPool(host='api.alliance.carbonblack.com', port=443): Max retries exceeded with url: /api/v1/reputation/module/meta (Caused by <class 'socket.gaierror'>: [Errno -2] Name or service not known)
Cause
The "Max retries exceeded" message for the URL "api.alliance.carbonblack.com" could not be reached due to no internet access from the Enterprise Server. It is a requirement that internet access is available, either directly or by proxy.
Solution
To resolve the issue, either:
- Allow direct internet access from the Enterprise Server, or
- If the Enterprise server resides within a DMZ, allow internet access by configuring a proxy: Carbon Black - How to configure a web proxy.
Important Note(s)
Also note that internet access is required on the Enterprise server for installation, and performing any Carbon Black upgrade.