Environment
- Carbon Black Cloud Console: All Versions
- Carbon Black Cloud Sensor: All Versions
- Apple macOS: All Supported Versions
- Microsoft Windows: All Supported Versions
- Linux: All Supported Versions
Symptoms
"OS" and "SENSOR" information in Inventory page (Endpoints, VM Workloads, VDI Clones) is missing / blank / empty
Cause
Sensor installation fails on the local device after successful registration. This causes the sensor version and OS Version to not be reported.
Resolution
- Check if all the required ports and URLs are allowed in Firewall/Proxy: https://community.carbonblack.com/t5/Knowledge-Base/Carbon-Black-Cloud-What-Ports-must-be-opened-on-...
- Try to reboot the device, and see if it can help to bring the OS and Sensor info back to the console.
- If Step 2 doesn't help, try to uninstall and reinstall the sensor to see if i can help to fix the issue
- If the issue still persists, create a Support ticket and provide the following items to Tech Support team:
- the cmd.exe output from Step 3;
- msi.log from the path running installation command
- installer.log from one of the following possible locations:
- Windows: C:\Windows\TEMP\
- Windows: C:\Users\<user>\AppData\Local\Temp\
- Windows: C:\Users\All Users\AppData\Local\Temp
- Mac: The equivalent of confer-temp.log on mac is confer-preinstall-xxxxxxxx.log & confer-postinstall-xxxxxxx.log/tmp
- Mac: /Applications/Confer.app/
Additional Notes
- Always make sure the required ports and URLs are allowed in Firewall/Proxy first
- To find all devices where installation has failed, search for:
-sensorVersion:*
- In order for a device record to show up on an Inventory page, registration must have succeeded
- If a record does not appear on an Inventory page for a given hostname, both registration and installation have failed
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