IMPORTANT ANNOUNCEMENT: On May 6, 2024, Carbon Black User eXchange (UeX) and Case Management will move to a new platform!
The Community will be in read-only mode starting April 19th, 7:00 AM PDT. Check out the blog post!
You will still be able to use the case portal to create and interact with your support cases until the transition, view more information here!

Carbon Black Cloud Sensor: Unable to access certain directories in Live Response on Mac

Carbon Black Cloud Sensor: Unable to access certain directories in Live Response on Mac

Environment

  • Carbon Black Cloud Sensor: 3.2.1 and Higher
  • macOS 10.14.x Mojave

Symptoms

  • Unable to access certain directories such as /Users/<username>/Library/Mail/ in a Live Response session, with an error such as: 
    Remote error 0x80070002 - The system cannot find the file specified
    Remote error 0x80070001 - Incorrect function

     

Cause

Full Disk Access has not been provided to the CB Defense process in System Preferences

Resolution

  1. Open System Preferences and navigate to Security & Privacy>Privacy tab
  2. Click "Full Disk Access" in the sidebar and ensure the CB Defense process "com.carbonblack.defense.ui" is enabled (Administrator credentials may be required to make this change)
These steps can be completed by any Administrator User.

Additional Notes

  • This requirement is due to a macOS security measure
  • Full Disk Access is required to access certain User or System directories protected by macOS
  • See the article in related content for more detail on this requirement, along with an example of how to manage this with an MDM solution

Related Content


Was this article helpful? Yes No
No ratings
Article Information
Author:
Creation Date:
‎09-09-2020
Views:
1302