Environment
- Carbon Black Cloud Console
- Google Authenticator App
- Android Devices: All Versions
- Apple iOS: All versions
Symptoms
- Your administrator or Carbon Black Support has reset your Google Authentication
- You log in to Carbon Black Console and scan the new barcode with your Android or iOS device.
- You enter the new Authenticator code when prompted.
- You get the "Failed at second-factor authentication: the passcode doesn't match" error when logging in.
Cause
The time on the Google Authenticator app is not synced correctly.
Resolution
- Android devices:
- Go to the main menu of the Google Authenticator app
- Tap More, then Settings.
- Tap Time correction for codes.
- Tap Sync now.
- Apple iOS devices:
- From the device itself, tap on "Settings"
- Tap on "Privacy"
- Tap on "Location Services"
- Swipe the slider to the right to enable Location Services. Once enabled, the Slider will be green
Additional Notes
Your Authenticator codes may not be working because the time in the Google Authenticator app is not synced correctly. Android devices have a "sync now" feature that fixes this, however, the iOS device app depends on Location Services to be turned on for the app to sync correctly.
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