Environment
- CB Defense PSC Console: All Versions
- CB ThreatHunter Console: All Versions
- CB Defense PSC Sensor: 3.2.1.51 - 3.4.0.1047
- Microsoft Windows: All Supported Versions
Symptoms
Cause
This issue can happen if the currently installed sensor was installed by Group Policy and Group Policy is still actively managing the sensor.
Resolution
PREVENTION ACTIONS
(If upgrade has not already been attempted using GPO Software Installation)
REMEDIATION ACTIONS
(If upgrade has already been attempted using GPO Software Installation)
- Upgrade may still be possible using other software deployment methods. If not, then sensor will need to be uninstalled and re-installed. See additional notes for more information.
Additional Notes
- If HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Group Policy\AppMgmt\{CB Defense GUID} registry key still exists on the device, then uninstall is not required. Simply configure GPO to allow future sensor upgrades via other deployment methods (Ex: manual, CB Defense Web Console) using using the instructions documented in PSC: How to Configure GPO to Allow Sensor Upgrades
- If HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Group Policy\AppMgmt\{CB Defense GUID} registry does not exist on the device, then the sensor will need to be uninstalled and re-installed, but uninstall will no longer be possible using GPO. Use one of the other uninstall methods documented in Endpoint Standard: How to Uninstall Windows Sensor
- At this time GPO/Manual Upgrades are successful only if GPO installed 3.4.0.1052 and above
- GPO/Manual Upgrades will be successful as long as the upgrade version is not 3.3.984 and above
Related Content