Cb Defense: Sensor Will Not Register Or Receive Updates When Behind Proxy Or Firewall

Cb Defense: Sensor Will Not Register Or Receive Updates When Behind Proxy Or Firewall

Environment

  • Cb Defense Sensor: All Versions
  • Microsoft Windows: All Supported Versions
  • Apple MacOS: All Supported Versions

Symptoms

  • System has a valid internet connection and meets installation requirements set forth in the User Guide
  • Sensor does not register at time of installation
  • Sensor does not receive signature update
  • Firewall logs show outbound connections to "*.conferdeploy.net" (using various IPs) over port 443 and then immediately followed by attempts to communicate over port 54443.

Cause

Some proxy and or firewall devices break the SSL communication path or require proxy authentication between sensors and the cloud backend. These symptoms may occur even if a firewall rule is in place to allow traffic to the destination "*.conferdeploy.net".

Resolution

  1. Create an SSL whitelist (no decryption) exception to any proxy and or firewall devices inline of the communication path to "*.conferdeploy.net".
  2. If the environment is using proxy authentication follow the steps outlined here: Cb Defense: Does the sensor support proxy server authentication?

Additional Notes


Related Content


Was this article helpful? Yes No
No ratings
Article Information
Author:
Creation Date:
‎02-21-2018
Views:
4114
Contributors