Environment
- Cb Protection 8.x
- Windows 10
Symptoms
- Upgrading to an Anniversary or later OS upgrade for Windows 10 takes an extended period of time.
- Takes place when doing full OS Upgrades such as from Windows 7 to Windows 10. Or from Windows 10 to a different version of Windows 10 such as 1709.
Cause
The cause of this likely one of two main reasons.
- Anti-Virus is installed on the endpoint, and that, plus the Cb Protection Agent are adding a large amount of time for each item processed.
- WIM files were not placed in a trusted directory.
Resolution
- The main resolution for this issue, as outlined in the release notes, is to always disable Anti-Virus before running the upgrade. The main culprit for this is the Windows Defender Advanced Threat Protection, although other AV have been seen to interact with the upgrade and the Cb Protection Agent.
- Because the OS upgrades have a ton of files related to Windows Defender, its also helpful to have the Windows Defender updater enabled in the Cb Protection Console.
- Lastly its important that the OS files were added to a trusted directory, and that all other steps listed in the release notes have been followed. A link to these release notes can be found below. As of writing, the second on OS upgrades can be found starting on page 16.
Additional Notes
The best resource for any changes to the OS Upgrade proceedure will be listed in the Cb Protection Release notes, which can be found at the following link:
Cb Protection v8.0.0 - Release Notes