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Cb Protection: When Creating a Trusted Directory you Receive "No results found" for the Computer Field

Cb Protection: When Creating a Trusted Directory you Receive "No results found" for the Computer Field

Environment

  • Cb Protection 8.x

Symptoms

  • When creating a trusted directory and entering the "Computer" field, you receive "No results found" in the search.

Cause

The certificate in IIS is expired, has the incorrect CN and the certificate on Trusted Root Certification Authority has incorrect information, or the server certificate has been updated and the IIS certificate was not.

Resolution

  1. In the Cb Protection console, navigate to System Configuration (gear icon in 8.x) > Security Tab. Make note of the certificate (Common Name and Expiration date) information shown.
  2. On the Cb Protection server, go to Start > Run > type “mmc” > click OK.
  3. In the Microsoft Management Console (mmc) window, go to the File menu > click on “Add/Remove Snap-in”
  4. Select “Certificates” > click the “Add” button
  5. Select “Computer account” > click “Next” > select “Local computer” > click “Finish” > then, click “OK”
  6. Click the plus sign on “Certificates” to expand it
  7. Click the plus sign on “Trusted People” to expand it > select “Certificates”
  8. On the right-pane, there should be a certificate for the Cb Protection console > double-click to open the properties
    1. On the General tab, note the expiration date to make sure that it matches what is shown on the Cb Protection console (see step #2 above)
    2. On the Details tab, select Subject and note the information displayed to make sure that it matches what is shown on the Cb Protection console (see step #2 above)
  9. Once verified that the certificate it valid, highlight the Certificate and Right Click > All Tasks > Export.
  10. Export the certificate (Export the private key, provide a Password and select a location for the exported certificate).
  11. On the navigation tree on the left-pane, click on the plus sign for “Trusted Root Certification Authorities” to expand it > select “Certificates”
  12. Repeat steps 8a and 8b. If the certificate in “Trusted Root Certification Authorities” is incorrect, delete it and import the one from “Trusted People” to “Trusted Root Certification Authorities”
  13. Close the Microsoft Management Console (mmc) window
  14. Open IIS Manager
  15. On the IIS Manager navigation tree on the left-pane, select the server name
  16. On the right-pane, double click on Server Certificates
  17. Delete the old Cb Protection certificate
  18. Under the “Actions”, click on “Import”  and select the exported Certificate file from step 10 and provide the password
  19. On the IIS Manager navigation tree on the left-pane, expand “Sites” and select “Parity Console Web”
  20. On the “Action”, select “Bindings…” > click on https 443 and click Edit
  21. On the “SSL certificate” drop-down, select the new certificate you imported in step# 19) > click OK
  22. On the IIS Manager window, click Restart or run the “iisreset” on the command prompt (you need to be an administrator to do this)
  23. Restart the Cb Protection Server service. (May be called Parity Server service in older versions)

Additional Notes

N/A

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Creation Date:
‎02-26-2018
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