Environment
Cb Protection Console: All Supported Versions
Symptoms
- "Unable to access rules XML" Error when accessing Rules > Policies > Mappings tab within console
- Cb Protection Server service crashes while trying to access mappings (seen in Event Viewer - System logs)
Cause
A group or OU that a policy mapping points to, no longer exists within Active Directory.
Resolution
- Login to the Cb Protection server.
- Open Services > Stop the CB Protection Server service
- Navigate to C:\Program Files (x86)\Bit9\Parity Server\scripts.
- Open the 'adrules.xml' with Notepad
- Remove any mappings that are no longer applicable and save the file
- Open SQL Mgmt Studio and run the following query to clear the DB copy of the file:
use das; delete dbo.file_streams where name = 'adrules.xml'
- Start the CB Protection Server service
Additional Notes
Carbon Black has identified this issue internally as EP-4090