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Cb Response: No information is appearing after DEBUG logging is enabled for SSO

Cb Response: No information is appearing after DEBUG logging is enabled for SSO

Environment

  • Cb Response 6.1.2+

Symptoms

  • Login attempts with SSO fail, but no Debug information is logged in /var/log/cb/coreservices/debug.log
  • Debug logging was added for cb.flask.api_routes_saml

Cause

Due to a code change in server version 6.1.2, the path to saml debugging has changed from cb.flask.api_routes_saml to cb.flask.blueprints.api_routes_saml.

Resolution

This resolution assumes you have already applied debug settings as outlined on page 57 of the Cb Response 6.2 Integration Guide

  1. Edit /etc/cb/coreservices-logger.conf, changing all references of cb.flask.api_routes_saml to cb.flask.blueprints.api_routes_saml
  2. Once changes are saved, restart services
    1. For a standalone server:
      service cb-enterprise restart
    2. For a cluster:
      /usr/share/cb/cbcluster stop
      /usr/share/cb/cbcluster start

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Creation Date:
‎05-22-2018
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