Just Published! Threat Report: Exposing Malware in Linux-Based Multi-Cloud Environments | Download Now

Error during Bit9 Server upgrade - "Please make sure the Basic Authentication support is enabled"

Error during Bit9 Server upgrade - "Please make sure the Basic Authentication support is enabled"

Version

Applies to all versions of Bit9

Issue

While performing an upgrade to the Bit9 Server, the following error message is given:

Bit9 Console could not be deployed on IIS

Please make sure the BasicAuthentication support is enabled on IIS and try again

Cause

During the initial installation of Bit9, several required IIS features are detailed, as well as several SQL Server database permissions. After the installation is complete, it is noted that some of those permissions may be removed if chosen.  Those permissions need to be added back to the server when performing an upgrade.

Solution

In the IIS Roles Manager, both of the following need to be re-enabled if they were removed:

  • Basic Authentication
  • Directory Browsing

In SQL Server, the user account used to access the database needs to have the following re-enabled if it was removed:

  • Create Any Database

The above permissions can all be removed again after the upgrade is completed, if desired.

Was this article helpful? Yes No
No ratings
Article Information
Author:
Creation Date:
‎01-20-2016
Views:
386