Environment
- Cb Protection Server: Versions 7.x & 8.x
Symptoms
When performing an upgrade of the Cb Protection server, the following error message is displayed after accepting the license agreement
Connecting to Bit9 Database.
Bit9 Database cannot be accessed. Please verify your user credentials and try again.
Causes
Can be a result of 3 different causes:
- The Cb Protection agent is running on the server, and tamper protection is blocking the upgrade.
- The server upgrade is being ran by an account other than the service account.
- The shepherd.dsn configuration file uses the following format:
SERVER=LPC:<SERVER NAME>
(The LPC: portion is not supported by the installer)
Resolutions
- From the console, disable tamper protection for the agent running on the server. Then, stop the agent service from the Windows service manager. You can then proceed with the upgrade as normal, remembering to restart the agent service afterwards and enable tamper protection again.
- Sign into the Cb Protection server as the service account, and then run the upgrade as normal.
- Edit the shepherd.dsn configuration file. The default file location is c:\program files (x86)\bit9\parity server\shepherd.dsn.
Remove the "LPC:" portion from the server entry: SERVER=<SERVER NAME>
Save the configuration file
Complete the upgrade as normal. After the upgrade is finished, the shepherd.dsn can be edited to add the LPC: portion back in.
Related Content
Upgrading your Carbon Black Protection Server
Cb Protection: Service Account Permissions
Cb Protection: How to Change Service Account Credentials
Cb Protection: Unable to access database after SA account password change