Just Published! Threat Report: Exposing Malware in Linux-Based Multi-Cloud Environments | Download Now

Mail Server Doesn't Accept Anonymous Settings

Mail Server Doesn't Accept Anonymous Settings

Version

Cb Response 5.2.x, 6.x

Issue

While configuring email alerts through your Own Mail Server the UI requires that the username and password fields be filled in

Solution

Workaround

To manually set the email settings in postgres, follow these steps:

1) SSH to the master and elevate to root

2) Modify the following INSERT statement to replace 'mail.test.local' and '25' with your own SMTP server and port

psql -p 5002 cb -c "INSERT INTO communication_settings_history (timestamp,mail_server_type,smtp_server,smtp_port,smtp_connection_type,use_proxy,enabled,statistics,community_participation,smtp_password,smtp_username) VALUES (current_timestamp,'own','mail.test.local','25','insecure',false,true,true,false,'','');"

Note: Be mindful that the quotes inside the parentheses are single quotes, the ones outside are double quotes

Labels (1)
Was this article helpful? Yes No
No ratings
Article Information
Author:
Creation Date:
‎07-10-2017
Views:
771
Contributors