Version:
This solution applies to all versions of Bit9
Issue:
After Shift/Promoting the Dropbox installer, the user is still being prompted or blocked depending on enforcement.
Cause:
This is the expected behavior for the Bit9 Product. The root installer is spawning off a different installation process which is not tied to the root installer. That new installer is not part of the trust chain, and is subsequently blocked.
Workaround:
You can create a custom rule that would allow the Dropbox installer to run, if promoted, without blocks
The custom rule should be the following:
Rule Type: File Creation Control
Path:<LocalAppData>\temp\*
Process:<AppData>\dropbox\bin\dropbox.exe
You may have to modify the path/process to match your environment.