Access official resources from Carbon Black experts
Version
7.2.1, 7.2.2
Issue
Installation of new Windows 10 builds cannot complete when CB Enterprise Protection agent is installed
Symptom
When installing new major updates (builds) on Windows 10, it pauses the update so the CB Enterprise Protection agent could be uninstalled before moving on with the update.
Cause
Prior to Windows 10, upgrading Windows minor or major versions always required an uninstall of the CB Enterprise Protection agent, as stated in the CB Enterprise Protection User's Guide.
With Windows 10, Microsoft introduced a new concept of builds that are like entirely new version of Windows. For this reason the CB Enterprise Protection agent needs to be uninstalled in order for the build to successfully install (for example: applying Windows 10 build, such as the "November release", is similar to going from Windows 8 to Windows 8.1).
Solution
For updates to Windows 10 Anniversary Edition (August 2016) ONLY, starting version 7.2.3 there will be no need anymore to uninstall and re-install the agent . Additional information and supported upgrade paths can be found in this announcement.
Otherwise, the following 2 options are available:
1. Install all the latest Windows 10 updates prior to installing the Cb Enterprise Protection agent
2. If the agent is already deployed and a major Windows update is required, uninstall the agent when prompted to by the OS and reinstall after the upgrade is complete
Related Articles
Some system files are not approved after Windows 10 update
Copyright © 2005-2023 Broadcom. All Rights Reserved. The term “Broadcom” refers to Broadcom Inc. and/or its subsidiaries.