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Workload: Appliance Upgrade Fails Due to Root Password Expiration

Workload: Appliance Upgrade Fails Due to Root Password Expiration

Environment

  • Carbon Black Cloud Workload: All Versions
    • Appliance 1.0.0 - 1.0.1

Symptoms

  • Appliance upgrade fails
  • Error ""Last Upgrade is failed: Target Version: X" under Appliance UI > Appliance > Upgrade
  • cat /var/log/cwp/apw_upgrade_status.json shows status:
    "TIMEDOUT_WAIT_FOR_TERMINAL_STATUS"
  • "sudo chage -l root" gives output:
    You are required to change your password immediately (administrator enforced) 
    
    chage: PAM: Authentication token is no longer valid; new one required

Cause

Expired root password

Resolution

  1. Launch the Web Console for the Appliance
  2. Login as root, prompt to change password will appear.
  3. The upgrade process will start within one minute of updating the password. This process will cause various services to restart
  4. To verify successful upgrade run command:
    cat /var/log/cwp/upgrade_status.json
    
    Sample output:
    {"status": "COMPLETED", "message": "Upgrade completed successfully", "reboot_pending": true, "source_version": "1.0.0.0-17066560", "target_version": "1.0.1.0-17340318"}
    

Additional Notes

  • The Appliance comes with a password expiry policy of 90 days. If the Appliance is more than 90 days old, then root & admin passwords would have expired.
  • The Appliance upgrade process requires the root password to be active and not be expired.
  • Once the upgrade process has completed, the appliance UI may still show older version or the status as failed. This will automatically correct itself when the next upgrade schedule triggers.

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Creation Date:
‎03-04-2021
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1090