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Workload: Plugin error "no healthy upstream" or "503 service unavailable"

Workload: Plugin error "no healthy upstream" or "503 service unavailable"

Environment

Carbon Black Cloud Workload: All Versions

Symptoms

Plugin shows error "no healthy upstream" or error "503 Service unavailable (failed to connect to endpoint:...)"

Cause

  • Error occurs when the plugin is unable to communicate with the appliance
  • Appliance does not have a valid DNS server configured

Resolution

  1. Make sure appliance is up and running and VCenter can communicate with it
    • Appliance status can be viewed in the Carbon Black Console under Settings > API Access > Click on appliance in question.
  2. If appliance is running attempt de-registration and register SSO and vCenter from appliance

  3. If error persists then manually unregister plugin then repeat step 2


Additional Notes

In the Event that the appliance does not have a DNS server configuration please follow this Network Settings guide

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Creation Date:
‎12-03-2021
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