Just Published! Threat Report: Exposing Malware in Linux-Based Multi-Cloud Environments | Download Now

b9notifier install failure due to unresolved libicu dependency

b9notifier install failure due to unresolved libicu dependency

Version

7.2.x.

 

Issue

B9notifier install on a Linux machine is failing due to unresolved libicu dependency.

 

Symptoms

b9intall.log shows the following error (Bit9 build number may vary):

 

Error: Package: b9notifier-7.2.0-1253.el6.x86_64 (/b9notifier)

Requires: libicuuc.so.42()(64bit)

Error: Package: b9notifier-7.2.0-1253.el6.x86_64 (/b9notifier)

Requires: libicudata.so.42()(64bit)

Error: Package: b9notifier-7.2.0-1253.el6.x86_64 (/b9notifier)

Requires: libicui18n.so.42()(64bit)

 

Cause

The install has libicu dependency and it’s unable to resolve the symbolic link.

 

Solution

Run this command first before doing the Bit9 agent install:

sudo ln –s /usr/lib64/libicudata.so.42 /usr/lib64/libicudata.so
Labels (1)
Was this article helpful? Yes No
No ratings
Article Information
Author:
Creation Date:
‎01-07-2015
Views:
544
Contributors