The VMware Carbon Black Tech Zone is live! Checkout this great resource: Mastering Carbon Black Workload.
HurricaneRider
New Contributor II

CB Causes Backups to Fail

Jump to solution

I had a VM with the CB Sensor installed. CB added the line guestinfo.Cb/.Readytoclone = "true" to the VMX file. This line caused by backups of this VM to fail with the error Failed to parse "/.Readytoclone". I uninstalled the sensor from the VM and rebooted. The backup still failed. I then modified the VMX file to remove the readytoclone line. But, CB just adds it back. Does anyone know how to resolve this issue?

Thank you!

Labels (1)
1 Solution

Accepted Solutions
HurricaneRider
New Contributor II

Re: CB Causes Backups to Fail

Jump to solution

I fixed it:

Uninstall Carbon Black Sensor.
Shutdown the VM.
Remove the VM from inventory.
Remove the guestInfo variables that belong to Carbon Black from the VMX config file.
Register the VM with VMware.
Boot the VM.
Remove the VM from the backup job (because the new VM has a different vm-id).
Re-add the VM to the backup job.
Re-map the VM to any existing backups or replicas.

 

View solution in original post

0 Kudos
Reply
8 Replies
esullivan
Community Manager
Community Manager

Re: CB Causes Backups to Fail

Jump to solution

Hello. Can you please confirm which product this is in relation to so I can move this post to the correct forum for better visibility?

Thank you.
Ed Sullivan

0 Kudos
Reply
HurricaneRider
New Contributor II

Re: CB Causes Backups to Fail

Jump to solution
Carbon Black Workloads
0 Kudos
Reply
HurricaneRider
New Contributor II

Re: CB Causes Backups to Fail

Jump to solution

I fixed it:

Uninstall Carbon Black Sensor.
Shutdown the VM.
Remove the VM from inventory.
Remove the guestInfo variables that belong to Carbon Black from the VMX config file.
Register the VM with VMware.
Boot the VM.
Remove the VM from the backup job (because the new VM has a different vm-id).
Re-add the VM to the backup job.
Re-map the VM to any existing backups or replicas.

 

View solution in original post

0 Kudos
Reply
User107
New Contributor

Re: CB Causes Backups to Fail

Jump to solution

How do you prevent this from happening again? I had it happen to 1 VM ... now I have 8 VM's affected.  Come next week there will probably be more.  Whack a mole isn't fun to clean this up.  What's the long term fix/prevention?  And any idea why this just started happening?

0 Kudos
Reply
jamorris
New Contributor

Re: CB Causes Backups to Fail

Jump to solution

While this solution does work for several servers that backups are failing on, we have 600 servers in our environment. So, touching each .vmx file is not an option if they all get these lines in their file. 

Since we have this happening, but not to all servers, what causes the code to be added to certain servers? Will it be pushed to all servers? We have CB on all servers now but it has only gotten on about 20 different servers. 7 of those had the lines, we removed it, and then they came back after last months maintenance reboot.

Since we have a monthly maintenance coming up where all servers are restarted, we had to shut down the CB appliance to prevent the vmx files from being updated and stopping backups.

We have someone at Veeam trying to see when Veeam will release the fix for this. In the meantime, this has created quite a headache.

 

0 Kudos
Reply
User107
New Contributor

Re: CB Causes Backups to Fail

Jump to solution

Veeam support got me this info today on it:

Thank you for your patience on this. The Cumulative Patch that was recently released was a 'preview' of the upcoming patch. Due to some specific issues we wanted to address in the patch which requires further attention before releasing and other rather pending issues we wanted to address for customers right away, the decision was made to release a 'preview' patch that included those most critical fixes.
 
The fix for the issue you're experience was not included in the preview, and will likely be included in the next patch, but this is subject to change. I don't have an exact date yet so my apologies.

 

.....

 

They are working on it but seems they don't have an ETA yet.  SUPER annoying to say the least.  Wish there was some way to figure out which VM's would be effected or what triggers it to happen.  Feels random so far.

0 Kudos
Reply
Rick23
New Contributor

Re: CB Causes Backups to Fail

Jump to solution

Which backup product? I have same issue with Veeam Backup & Replication v.10. 

0 Kudos
Reply
weitong
New Contributor

Re: CB Causes Backups to Fail

Jump to solution

same issue on Veeam Backup & Replication 11

0 Kudos
Reply