Environment
- App Control Server (formerly CB Protection): All Supported Versions
- Non-English (US) Regional
Symptoms
- API Authentication failed
- Some pages will not be functional
- Log off and Log back in does not clear the error
- Install log shows the following errors
00004056 308.29238892 [5196] 6164 iisutil!ReadDwordParameterValueFromAnyService [helpfunc.cxx @ 152]:Opening registry key failed
00004057 308.29238892 [5196] Error(80070002): The system cannot find the file specified.
00004058 308.29238892 [5196]
00004059 308.29629517 [5196] 6164 iisutil!ReadStringParameterValueFromAnyService [helpfunc.cxx @ 384]:Inetinfo: Failed reading registry value
00004060 308.29629517 [5196] Error(80070002): The system cannot find the file specified.
00004061 308.29629517 [5196]
00004062 308.30340576 [5196] 6164 iisutil!ReadMultiStringParameterValueFromAnyService [helpfunc.cxx @ 490]:Inetinfo: Failed reading registry value
00004063 308.30340576 [5196] Error(80070002): The system cannot find the file specified.
00004064 308.30340576 [5196]
Cause
The patch utility is unable to find the registry values necessary for a successful upgrade, this is caused by the regional settings being outside of English (US)
Resolution
If the server is currently in this state
- Uninstall/Re-install the Carbon Black Protection application
If after the install has been reverted to the backup taken prior to upgrade
- Open Control Panel > Select "Region"
- Select the Administration Tab > "Change System Locale..."
- Change the Current System Locale to English (United States)
- Reboot the machine
- Perform the patch upgrade
Additional Notes
- This only affects the patching utility, the full installer does not experience this
- System Locale can be changed back to the true Region after successful upgrade
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