Threat Report: Exposing Malware in Linux-Based Multi-Cloud Environments | Download Now

App Control: Troubleshooting Disconnected Agents (Windows)

App Control: Troubleshooting Disconnected Agents (Windows)

Environment

  • App Control Agent: All Supported Versions
  • App Control Server: All Supported Versions
  • Microsoft Windows: All Supported Versions

Symptoms

  • Endpoints are showing as Disconnected in the Console under Assets > Computers.
  • Endpoints are not showing in the Console under Assets > Computers.
  • Endpoints are experiencing general communication issues with the App Control Server.

Cause

There are many reasons why an Agent could have difficulties communicating with the App Control Server.

Resolution

  1. If all Agents are disconnected, the Agent Communication Certificate may have expired and needs to be replaced.
  2. If Certificate Verification is enabled the Agent Communication Certificate may need to be imported on the endpoint(s).
  3. Test network connectivity between the endpoint and the Server Address.
  4. Verify the TLS & Cipher Suites enabled in the Operating System on the endpoint match those enabled on the application server.
  5. Verify the Agent does not show in Duplicate Computers.
  6. If using Active Directory Policy Mapping, verify Slow Lookups are not contributing to the issue.
  7. Verify the Agent is fully running by manually restarting it via the command line.
  8. If the issue persists, collect the Disconnected Agent Logs.

Labels (1)
Was this article helpful? Yes No
100% helpful (2/2)
Article Information
Author:
Creation Date:
‎09-18-2018
Views:
17354
Contributors