Environment
- App Control Console: All supported versions
Symptoms
Error message in the Administration > System Configuration > Licensing tab states license limit is exceeded
Cause
- Licensing limit has been reached for purchased subscription
OR
- If endpoints "In use" is more than endpoints installed on the instance, uninstalled or re-imaged endpoints may still be in the database and need to be cleared out. Note: More prominent for environments where machines are cloned based off a template
Resolution
- Go to Administration > System Configuration > Advanced Options
- Click the "Edit" button at the bottom of the page
- Find the "Old Computer Cleanup"
- Enable old computer clean-up based upon the amount of days desired before removing unconnected endpoints. Default is set to 30 in the console, but setting is not enabled by default
- Upon the next scheduled maintenance (every Saturday) the server will clean up the old endpoints and should clear the license error if there are less than licensed for connected
Additional Notes
- If environment has endpoints that may not connect for the number of days set in the old computer cleanup config, endpoints will clear from the console. Upon the next time the endpoint connects to the server it will be re-added to the console.
- Also, Contact your Carbon Black Sales representative to purchase additional licenses
- If there are assets that can be removed from App Control server that are no longer around, this will help save on license counts
- Move enough agents out of Control policies to comply with your Suite license limit. It can accomplish by either moving some of your computers to a different policy or by changing one or more policies to Visibility mode
- Move enough agents to Agent Disabled mode (and uninstall the agent if there is no plan to acquire more licenses) to comply with your license limits
- Exceeding license keep the product working and protecting the environment, but it is just getting the warning message
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