IMPORTANT ANNOUNCEMENT: On May 6, 2024, Carbon Black User eXchange (UeX) and Case Management will move to a new platform!
The Community will be in read-only mode starting April 19th, 7:00 AM PDT. Check out the blog post!
You will still be able to use the case portal to create and interact with your support cases until the transition, view more information here!

App Control: API is unavailable when viewing Approval Request

App Control: API is unavailable when viewing Approval Request

Environment

  • App Control Server: All versions 
  • Windows Server: All Supported Versions

Symptoms

  • API red dot status on Administration > System Configuration > Advanced Options > API Access Enabled
  • Blank User Roles when trying to edit or Create a new user.
  • Unable to view approvals request.
  • Unable to globally approve files.
  • Unable to view software rules page.
  •  API log file shows the following error:
    [13-Jan-2022 16:54:27 EST] API Error from page /support.php: GET <AppControlServerAddress>/api/bit9platform/v1/serverConfig/ with params {"q":"name:ShowCDCImportButtons"} with options {"81":0,"64":0,"19913":1,"42":0,"156":61000,"10023":"[removed from logging]","10022":"[removed from logging]","10015":"[removed from logging]"} returned http code 0 and result in 0.0047259330749512 seconds
    [13-Jan-2022 16:54:27 EST] Last Curl error: HTTP/2 stream 0 was not closed cleanly: Unknown error code (err 8)

Cause

  • IPV6 is enabled in the App Control Server.
  • IP Adress and Domain Restrictions is enabled in IIS. 

Resolution

  1. Confirm ipv6 is enabled on the App Control Server by running the following command in an elevated command prompt: ipconfig 
    C:\Users\user>ipconfig
    
    Windows IP Configuration
    
    
    Ethernet adapter Ethernet:
    
       Connection-specific DNS Suffix  . :
       Link-local IPv6 Address . . . . . : fexx::xxyy:xxyy:xxyy:xxyy%12
       IPv4 Address. . . . . . . . . . . : 192.xxx.x.x
       Subnet Mask . . . . . . . . . . . : 255.x.x.x
       Default Gateway . . . . . . . . . : 192.xx.x.x
  2. Open IIS.
  3. Expand sites
  4. Select Parity Console Web
  5. Do double click in IP Address and Domain Restrictions.
  6. Click on Add Allow Entry from the action menu.
  7. in the specific IP address enter the full IPv6 Address obtained in step 1, i.e .
    fexx::xxyy:xxyy:xxyy:xxyy%12
  8. Click ok.
  9. Open a CMD executed as administartion enter the following command:
    IISreset

Additional Notes

Please note troubleshooting API issues is not an easy task and although the symptom and log entries are the same the resolution may vary between the scenarios. Please refer to 'Related Content' for more guidance. 
 

Related Content


Labels (1)
Was this article helpful? Yes No
No ratings
Article Information
Author:
Creation Date:
‎01-27-2022
Views:
496
Contributors