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App Control: Certificate with specified subject not found. Agents will not be able to connect to the server

App Control: Certificate with specified subject not found. Agents will not be able to connect to the server

Environment

  • App Control Server (Formerly CB Protection): All Supported Versions

Symptoms

  • After logging into the console the following error is displayed in red text across each page:
    Certificate with specified subject not found. Agents will not be able to connect to the server
  • Agents disconnected

Cause

This issue occurs when a user manually deletes the agent communication certificate from the Windows Trust Store on the App Control application server.
 

Resolution

  • If you have a backup of the certificate you can navigate to System Configuration > Security > Choose File in the Import Server Certificate From PKCS12 File.
  • If you do not have a backup of the certificate you can generate a new certificate using the following KB solution

Additional Notes

  • To determine which certificate the App Control Server is looking for, run query:
    use das; select * from das.dbo.shepherd_configs with (nolock) where name = 'sslcertificate'

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Creation Date:
‎11-26-2018
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