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App Control Console: Agent Diagnostics File Increases Size Each Time It Is Requested Remotely via Console

App Control Console: Agent Diagnostics File Increases Size Each Time It Is Requested Remotely via Console

Environment

  • App Control Console: All Supported Versions
  • App Control Agent: All Supported Versions

Symptoms

  • Agent diagnostics file increases with each request via the Console.
  • Agent diagnostics grows exponentially, causing the upload to be very slow and timeout eventually.

Cause

Previous Agent Diagnostics files are getting collected with each new request, resulting in an increasingly larger Agent Diagnostics archive.

Resolution

Delete Agent Diagnostics via Console (Remotely):
  1. Login to App Control Console and navigate to Assets > Computers > relevant Computer.
  2. From the Computer Details page > right-hand menu > Other Actions > Delete Diagnostics files on computer > Go.
Delete Agent Diagnostics Locally:
  1. Temporarily disable Tamper Protection.
  2. Delete the diagnostic archive(s) from the relevant directory:
  • Windows: C:\ProgramData\Bit9\Parity Agent\Logs
  • Linux: /srv/bit9/data/Logs
  • Mac: /Library/Application Support/com.bit9.Agent/Logs

Additional Notes

  • By default the Agent will delete zipped diagnostics older than 90 days.
  • This max age can be adjusted by adding an Agent Config with the Value (example for 45 days):
    max_age_zipped_diagnostic_file_days=45

     

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Creation Date:
‎10-12-2021
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